PathOfTravelFindShortestPaths Method |
For a floor plan view, calculates paths from each start point to its closest destinations.
Returns the path, represented by an array of XYZ points.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<IList<XYZ>> FindShortestPaths(
View DBView,
IList<XYZ> destinationPoints,
IList<XYZ> startPoints
)
Public Shared Function FindShortestPaths (
DBView As View,
destinationPoints As IList(Of XYZ),
startPoints As IList(Of XYZ)
) As IList(Of IList(Of XYZ))
public:
static IList<IList<XYZ^>^>^ FindShortestPaths(
View^ DBView,
IList<XYZ^>^ destinationPoints,
IList<XYZ^>^ startPoints
)
static member FindShortestPaths :
DBView : View *
destinationPoints : IList<XYZ> *
startPoints : IList<XYZ> -> IList<IList<XYZ>>
Parameters
- DBView View
-
The floor plan view to use when computing the points.
- destinationPoints IListXYZ
-
Destination points. The input Z coordinates are ignored and set to the view's level elevation.
- startPoints IListXYZ
-
Start points for which shortest paths are calculated.
Return Value
IListIListXYZ
Array of paths calculated from each start point to its corresponding closest destination.
If a path cannot be caculated the corresponsing sub-array is set to an empty array.
Exceptions
Remarks
The calculation is done in a floor plan with one or more destinationPoints and one or more startPoints.
The shortest path is calculated from each start point to its closest destination point.
See Also