PathOfTravelSetWaypoint Method |
Updates the specified waypoint.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetWaypoint(
XYZ waypoint,
int index
)
Public Sub SetWaypoint (
waypoint As XYZ,
index As Integer
)
public:
void SetWaypoint(
XYZ^ waypoint,
int index
)
member SetWaypoint :
waypoint : XYZ *
index : int -> unit
Parameters
- waypoint XYZ
-
The new point for the waypoint.
- index Int32
-
The index of the waypoint to update.
ExceptionsException | Condition |
---|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
Index refers to a non-existent waypoint.
-or-
This functionality is not available in Revit LT.
-or-
Cannot perform this operation for a path of travel in a group.
|
See Also