FormatOptions Class

Options for formatting numbers with units.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFormatOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FormatOptions : IDisposable

The FormatOptions type exposes the following members.

Constructors
 NameDescription
Public methodFormatOptions Creates a new FormatOptions object that represents default formatting.
Public methodFormatOptions(ForgeTypeId) Creates a new FormatOptions object that represents custom formatting.
Public methodFormatOptions(FormatOptions) Creates a copy of a FormatOptions object.
Public methodFormatOptions(ForgeTypeId, ForgeTypeId) Creates a new FormatOptions object that represents custom formatting.
Top
Properties
 NameDescription
Public propertyAccuracy The accuracy to which values will be rounded.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyRoundingMethod The method used to round values: round to nearest, round up, or round down.
Public propertySuppressLeadingZeros Indicates if leading zeros should be suppressed in feet and fractional inches.
Public propertySuppressSpaces Indicates if spaces around the dash should be suppressed in feet and fractional inches.
Public propertySuppressTrailingZeros Indicates if trailing zeros after the decimal point should be suppressed.
Public propertyUseDefault Indicates whether default or custom formatting should be used.
Public propertyUseDigitGrouping Indicates if digit grouping symbols should be displayed.
Public propertyUsePlusPrefix Indicates if a plus sign prefix should be displayed for positive and zero values.
Top
Methods
 NameDescription
Public methodCanHaveSymbol Checks whether a symbol can be specified to display the unit in this FormatOptions.
Public methodStatic memberCanHaveSymbol(ForgeTypeId) Checks whether a symbol can be specified to display a given unit.
Public methodCanSuppressLeadingZeros Checks whether leading zeros can be suppressed for the display unit in this FormatOptions.
Public methodStatic memberCanSuppressLeadingZeros(ForgeTypeId) Checks whether leading zeros can be suppressed for a given unit.
Public methodCanSuppressSpaces Checks whether spaces can be suppressed for the display unit in this FormatOptions.
Public methodStatic memberCanSuppressSpaces(ForgeTypeId) Checks whether spaces can be suppressed for a given unit.
Public methodCanSuppressTrailingZeros Checks whether trailing zeros can be suppressed for the display unit in this FormatOptions.
Public methodStatic memberCanSuppressTrailingZeros(ForgeTypeId) Checks whether trailing zeros can be suppressed for a given unit.
Public methodCanUsePlusPrefix Checks whether a plus prefix can be displayed for the display unit in this FormatOptions.
Public methodStatic memberCanUsePlusPrefix(ForgeTypeId) Checks whether a plus prefix can be displayed for a given unit.
Public methodDisposeReleases all resources used by the FormatOptions
Public methodGetSymbolTypeId Gets the identifier of the symbol indicating the unit quantifying the value.
Public methodGetUnitTypeId Gets the identifier of the unit used to quantify values.
Public methodGetValidSymbols Gets the identifiers of all valid symbols for the unit in this FormatOptions.
Public methodStatic memberGetValidSymbols(ForgeTypeId) Gets the identifiers of all valid symbols for a given unit.
Public methodIsValidAccuracy(Double) Checks whether an accuracy is valid for the display unit in this FormatOptions.
Public methodStatic memberIsValidAccuracy(ForgeTypeId, Double) Checks whether an accuracy is valid for a given unit.
Public methodIsValidForSpec Checks whether this FormatOptions is valid for a given spec.
Public methodIsValidSymbol(ForgeTypeId) Checks whether a symbol is valid for the unit in this FormatOptions.
Public methodStatic memberIsValidSymbol(ForgeTypeId, ForgeTypeId) Checks whether a symbol is valid for a given unit.
Public methodSetSymbolTypeId Sets the symbol that should be displayed to indicate the unit quantifying the value.
Public methodSetUnitTypeId Sets the unit used to quantify values.
Top
Remarks

The FormatOptions class contains settings that control how to format numbers with units as strings. It contains those settings that are typically chosen by an end user in the Format dialog and stored in the document.

The FormatOptions class is used in two different ways. A FormatOptions object in the Units class represents the default settings for the document. A FormatOptions object used elsewhere represents settings that may optionally override the default settings.

The UseDefault property controls whether a FormatOptions object represents default or custom formatting. If UseDefault is true, formatting will be according to the default settings in the Units class, and none of the other settings in the object are meaningful. If UseDefault is false, the object contains custom settings that override the default settings in the Units class. UseDefault is always false for FormatOptions objects in the Units class.

See Also