ColorFillSchemeParameterDefinition Property |
Represents the parameter of the elements that this scheme could be used to color.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId ParameterDefinition { get; set; }
Public Property ParameterDefinition As ElementId
Get
Set
public:
property ElementId^ ParameterDefinition {
ElementId^ get ();
void set (ElementId^ value);
}
member ParameterDefinition : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The paramId cannot be applied to the scheme.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
Remarks
When this property changed, all existing scheme entries will be removed from the scheme,
and the value of
IsByRange property will be set to false if the parameter
storage type is not numeric.
See Also