ApplicationEntryPoint Class

For Revit Macros use only.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.ApplicationServicesApplication
    Autodesk.Revit.DB.MacrosApplicationEntryPoint

Namespace: Autodesk.Revit.DB.Macros
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public abstract class ApplicationEntryPoint : Application, 
	IEntryPoint

The ApplicationEntryPoint type exposes the following members.

Constructors
 NameDescription
Public methodApplicationEntryPointInitializes a new instance of the ApplicationEntryPoint class
Top
Properties
 NameDescription
Public propertyAddinFolder The full path to the Revit Macros module.
Top
Methods
 NameDescription
Public methodFinishInitializationEO For Revit Macros internal use only.
Public methodInitialize For Revit Macros internal use only.
Public methodOnShutdownEO For Revit Macros internal use only.
Top
Events
 NameDescription
Top
See Also