ApplicationEntryPoint Class

For Revit Macros use only.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.ApplicationServicesApplication
    Autodesk.Revit.DB.MacrosApplicationEntryPoint

Namespace: Autodesk.Revit.DB.Macros
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public abstract class ApplicationEntryPoint : Application, 
	IEntryPoint

The ApplicationEntryPoint type exposes the following members.

Constructors
 NameDescription
Public methodApplicationEntryPointInitializes a new instance of the ApplicationEntryPoint class
Top
Properties
 NameDescription
Public propertyActiveAddInIdRetrieves the Id of the currently running external application.
(Inherited from Application)
Public propertyAddinFolder The full path to the Revit Macros module.
Public propertyAllowNavigationDuringRedraw Checks whether or not the navigation during redraw is enabled, and enable or disable it.
(Inherited from Application)
Public propertyAllUsersAddinsLocation The folder location for .addin files for all users.
(Inherited from Application)
Public propertyAngleTolerance Angle tolerance.
(Inherited from Application)
Public propertyBackgroundColor The background color to use for model views in this session.
(Inherited from Application)
Public propertyCode exampleCitiesReturns a set of all the known city locations within Revit.
(Inherited from Application)
Public propertyCreateProvides an object that can be used to create new instances of Autodesk Revit API objects.
(Inherited from Application)
Public propertyCurrentRevitServerAccelerator Current Revit Server accelerator.
(Inherited from Application)
Public propertyCurrentUserAddinsLocation The folder location for .addin files for the current user.
(Inherited from Application)
Public propertyCurrentUsersAddinsDataFolderPath Path to AddinsData folder for the current user.
(Inherited from Application)
Public propertyCurrentUsersDataFolderPath Path to data folder for the current user.
(Inherited from Application)
Public propertyDefaultIFCProjectTemplate Full path to the default template file for new IFC project documents. It may be empty, in which case the DefaultProjectTemplate should be used.
(Inherited from Application)
Public propertyDefaultProjectTemplate Full path to the default template file for new project documents.
(Inherited from Application)
Public propertyDefaultViewDiscipline The view discipline that will be applied to new views by default.
(Inherited from Application)
Public propertyDocuments Returns a set of documents within Revit.
(Inherited from Application)
Public propertyExportIFCCategoryTable Full path to the file that defines Revit category to IFC entity mappings for IFC export.
(Inherited from Application)
Public propertyFamilyTemplatePath Default path for family template files.
(Inherited from Application)
Public propertyImportIFCCategoryTable Full path to the file that defines IFC entity to Revit category mappings for IFC import.
(Inherited from Application)
Public propertyIsArchitectureEnabled Checks whether or not the architecture discipline is enabled, and enable or disable it.
(Inherited from Application)
Public propertyIsElectricalAnalysisEnabled Checks whether or not electrical analysis is enabled, and enable or disable it.
(Inherited from Application)
Public propertyIsElectricalEnabled Checks whether or not the electrical discipline is enabled, and enable or disable it.
(Inherited from Application)
Public propertyIsEnergyAnalysisEnabled Checks whether or not energy analysis is enabled, and enable or disable it.
(Inherited from Application)
Public propertyIsInfrastructureEnabled Checks whether or not infrastructure discipline is enabled, and enable or disable it.
(Inherited from Application)
Public propertyIsMassingEnabled Checks whether or not the massing and site tools are enabled, and enable or disable them.
(Inherited from Application)
Public propertyIsMechanicalAnalysisEnabled Checks whether or not mechanical analysis is enabled, and enable or disable it.
(Inherited from Application)
Public propertyIsMechanicalEnabled Checks whether or not the mechanical discipline is enabled, and enable or disable it.
(Inherited from Application)
Public propertyIsPipingAnalysisEnabled Checks whether or not piping analysis is enabled, and enable or disable it.
(Inherited from Application)
Public propertyIsPipingEnabled Checks whether or not the piping discipline is enabled, and enable or disable it.
(Inherited from Application)
Public propertyIsRouteAnalysisEnabled Checks whether or not route analysis is enabled, and enable or disable it.
(Inherited from Application)
Public propertyIsStructuralAnalysisEnabled Checks whether or not the structural analysis is enabled, and enable or disable it.
(Inherited from Application)
Public propertyIsStructureEnabled Checks whether or not the structure discipline is enabled, and enable or disable it.
(Inherited from Application)
Public propertyIsSystemsEnabled Checks whether or not any systems disciplines (mechanical, electrical, or piping) are enabled.
(Inherited from Application)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Application)
Public propertyLanguageThe language used in the current session of Revit.
(Inherited from Application)
Public propertyLoginUserId The user id of the user currently logged in. The user id will be empty if the user is not logged in.
(Inherited from Application)
Public propertyPointCloudsRootPath Root path for point cloud files.
(Inherited from Application)
Public propertyProduct The product type for the current session of Revit.
(Inherited from Application)
Public propertyRecordingJournalFilename Retrieve the name of the journal file the Revit is currently recording to.
(Inherited from Application)
Public propertySharedParametersFilenameContains the fully qualified path to a shared parameters file.
(Inherited from Application)
Public propertyShortCurveTolerance The enforced minimum length for any curve created by Revit.
(Inherited from Application)
Public propertyShowGraphicalOpenEndsAreaBasedLoadBoundaryDisconnects Whether or not to show the graphical open ends for Area Based Load Boundary disconnects.
(Inherited from Application)
Public propertyShowGraphicalWarningCableTrayConduitDisconnects Whether or not to show the graphical warnings for CTC disconnects.
(Inherited from Application)
Public propertyShowGraphicalWarningDuctDisconnects Whether or not to show the graphical warnings for duct disconnects.
(Inherited from Application)
Public propertyShowGraphicalWarningElectricalDisconnects Whether or not to show the graphical warnings for Electrical disconnects.
(Inherited from Application)
Public propertyShowGraphicalWarningHangerDisconnects Whether or not to show the graphical warnings for Fabrication Hanger disconnects.
(Inherited from Application)
Public propertyShowGraphicalWarningPipeDisconnects Whether or not to show the graphical warnings for Pipe disconnects.
(Inherited from Application)
Public propertySubVersionNumber The minor version number of Revit
(Inherited from Application)
Public propertySystemsAnalysisWorkfilesRootPath Root path for systems analysis workfiles
(Inherited from Application)
Public propertyUsername Gets the user name for the current Revit session.
(Inherited from Application)
Public propertyVersionBuild Returns the internal build number of the Autodesk Revit application.
(Inherited from Application)
Public propertyVersionName Returns the name of the Revit application.
(Inherited from Application)
Public propertyVersionNumber Return the primary version of the Revit application.
(Inherited from Application)
Public propertyVertexTolerance Vertex tolerance.
(Inherited from Application)
Top
Methods
 NameDescription
Public methodCopyModel Copies an existing model to a new file. Overwriting a file of the same name is allowed.
(Inherited from Application)
Public methodDispose
(Inherited from Application)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodExtractPartAtomFromFamilyFile Writes a PartAtom XML from the contents of a family file.
(Inherited from Application)
Public methodFinishInitializationEO For Revit Macros internal use only.
Public methodGetAssets Gets all the Assets of the specified type.
(Inherited from Application)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodCode exampleGetLibraryPaths Returns path information identifying where Revit searches for content.
(Inherited from Application)
Public methodGetRevitServerNetworkHosts Gets the list of all Revit Server Network hosts in current session.
(Inherited from Application)
Public methodGetSystemsAnalysisWorkflowNames Returns names for systems analysis workflows.
(Inherited from Application)
Public methodGetSystemsAnalysisWorkflows Returns name and path information identifying systems analysis workflow files.
(Inherited from Application)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodGetWorksharingCentralGUID Gets the worksharing central GUID of the given server-based model.
(Inherited from Application)
Public methodInitialize For Revit Macros internal use only.
Public methodIsJournalPlaying Determines if the application is currently in journal playback mode.
(Inherited from Application)
Public methodCode exampleNewFamilyDocument New family document, including family, titleblock, and annotation symbol
(Inherited from Application)
Public methodNewProjectDocument(String) New project document
(Inherited from Application)
Public methodNewProjectDocument(UnitSystem) Creates a new project document with no template file specified.
(Inherited from Application)
Public methodNewProjectTemplateDocument New project template document
(Inherited from Application)
Public methodOnShutdownEO For Revit Macros internal use only.
Public methodOpenDocumentFile(String) Opens a document from disk.
(Inherited from Application)
Public methodCode exampleOpenDocumentFile(ModelPath, OpenOptions) Opens a document from disk or cloud.
(Inherited from Application)
Public methodOpenDocumentFile(ModelPath, OpenOptions, IOpenFromCloudCallback) Opens a document from disk or cloud.
(Inherited from Application)
Public methodOpenIFCDocument(String) Opens an IFC document from disk using default options.
(Inherited from Application)
Public methodOpenIFCDocument(String, IFCImportOptions) Opens an IFC document from disk using custom options.
(Inherited from Application)
Public methodOpenSharedParameterFileEnables access to shared parameter groups and definitions that are maintained on disk.
(Inherited from Application)
Public methodPurgeReleasedAPIObjects Explicitly purges all API objects that have been released but are still awaiting to be finalized
(Inherited from Application)
Public methodSetLibraryPaths Sets path information identifying where Revit searches for content.
(Inherited from Application)
Public methodSetSystemsAnalysisWorkflows Sets name and path information identifying systems analysis workflow files.
(Inherited from Application)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Public methodUpdateRenderAppearanceLibrary Updates the stored render appearance library, giving the Revit session access to any new RPC content.
(Inherited from Application)
Public methodWriteJournalComment Writes a comment to the Revit journal file.
(Inherited from Application)
Top
Events
 NameDescription
Public eventApplicationInitialized Subscribe to this event to get notified after the Revit application has been initialized
(Inherited from Application)
Public eventDocumentChanged Subscribe to the DocumentChanged event to be notified when Revit document has changed.
(Inherited from Application)
Public eventDocumentClosed Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
(Inherited from Application)
Public eventDocumentClosing Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
(Inherited from Application)
Public eventDocumentCreated Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
(Inherited from Application)
Public eventDocumentCreating Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
(Inherited from Application)
Public eventCode exampleDocumentOpened Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
(Inherited from Application)
Public eventDocumentOpening Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
(Inherited from Application)
Public eventCode exampleDocumentPrinted Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
(Inherited from Application)
Public eventCode exampleDocumentPrinting Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
(Inherited from Application)
Public eventDocumentReloadedLatest Subscribe to the DocumentReloadedLatestEventArgs event to be notified immediately after Revit has finished reloading a document with central model.
(Inherited from Application)
Public eventDocumentReloadingLatest Subscribe to the DocumentReloadingLatestEventArgs event to be notified when Revit is just about to reload latest changes from a central model.
(Inherited from Application)
Public eventDocumentSaved Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
(Inherited from Application)
Public eventDocumentSavedAs Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
(Inherited from Application)
Public eventDocumentSaving Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
(Inherited from Application)
Public eventCode exampleDocumentSavingAs Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
(Inherited from Application)
Public eventDocumentSynchronizedWithCentral Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.
(Inherited from Application)
Public eventDocumentSynchronizingWithCentral Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.
(Inherited from Application)
Public eventDocumentWorksharingEnabled Subscribe to the DocumentWorksharingEnabled event to be notified when a document has become workshared.
(Inherited from Application)
Public eventElementTypeDuplicated Subscribe to the ElementTypeDuplicated event to be notified immediately after Revit has finished duplicating an element type.
(Inherited from Application)
Public eventElementTypeDuplicating Subscribe to the ElementTypeDuplicating event to be notified when Revit is just about to duplicate an element type.
(Inherited from Application)
Public eventCode exampleFailuresProcessing Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
(Inherited from Application)
Public eventFamilyLoadedIntoDocument Subscribe to the FamilyLoadedInto event to be notified after Revit loaded a family into a document.
(Inherited from Application)
Public eventFamilyLoadingIntoDocument Subscribe to the FamilyLoadingInto event to be notified when Revit is just about to load a family into a document.
(Inherited from Application)
Public eventFileExported Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
(Inherited from Application)
Public eventFileExporting Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
(Inherited from Application)
Public eventFileImported Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
(Inherited from Application)
Public eventFileImporting Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
(Inherited from Application)
Public eventLinkedResourceOpened Subscribe to the LinkedResourceOpened event to be notified immediately after Revit has finished opening a linked resource.
(Inherited from Application)
Public eventLinkedResourceOpening Subscribe to the LinkedResourceOpening event to be notified when Revit is just about to open a linked resource.
(Inherited from Application)
Public eventProgressChanged Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.
(Inherited from Application)
Public eventViewExported Subscribe to the ViewExported event to be notified immediately after Revit has finished exporting a view of the document.
(Inherited from Application)
Public eventViewExporting Subscribe to the ViewExporting event to be notified when Revit is just about to export a view of the document.
(Inherited from Application)
Public eventCode exampleViewPrinted Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
(Inherited from Application)
Public eventCode exampleViewPrinting Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.
(Inherited from Application)
Public eventViewsExportedByContext Subscribe to the ViewsExportedByContext event to be notified immediately after Revit has finished exporting one or more views of the document via an export context by CustomExporter.
(Inherited from Application)
Public eventViewsExportingByContext Subscribe to the ViewsExportingByContext event to be notified when Revit is just about to export one or more views of the document via an export context by CustomExporter.
(Inherited from Application)
Public eventWorksharedOperationProgressChanged Subscribe to the WorksharedOperationProgressChanged to be notified when progress has changed during Collaboration for Revit's workshared operations: open model and synchronize with central.
(Inherited from Application)
Top
See Also