ApplicationNewProjectDocument(String) Method |
New project document
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic virtual Document NewProjectDocument(
string templateFileName
)
Public Overridable Function NewProjectDocument (
templateFileName As String
) As Document
public:
virtual Document^ NewProjectDocument(
String^ templateFileName
)
abstract NewProjectDocument :
templateFileName : string -> Document
override NewProjectDocument :
templateFileName : string -> Document
Parameters
- templateFileName String
- The template file name.
Return Value
Document
Exceptions
Remarks This command corresponds to New->Project command in the user-interface.
See Also