ApplicationIsMechanicalAnalysisEnabled Property |
Checks whether or not mechanical analysis is enabled, and enable or disable it.
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsMechanicalAnalysisEnabled { get; set; }
Public Property IsMechanicalAnalysisEnabled As Boolean
Get
Set
public:
property bool IsMechanicalAnalysisEnabled {
bool get ();
void set (bool value);
}
member IsMechanicalAnalysisEnabled : bool with get, set
Property Value
Boolean
ExceptionsException | Condition |
---|
InvalidOperationException |
When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
|
Remarks
Enabling mechanical analysis will not take effect unless the mechanical discipline is also enabled.
See Also