ApplicationIsInfrastructureEnabled Property |
Checks whether or not infrastructure discipline is enabled, and enable or disable it.
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsInfrastructureEnabled { get; set; }
Public Property IsInfrastructureEnabled As Boolean
Get
Set
public:
property bool IsInfrastructureEnabled {
bool get ();
void set (bool value);
}
member IsInfrastructureEnabled : bool with get, set
Property Value
Boolean
ExceptionsException | Condition |
---|
InvalidOperationException |
When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
|
See Also