ApplicationIsStructuralAnalysisEnabled Property |
Checks whether or not the structural analysis is enabled, and enable or disable it.
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsStructuralAnalysisEnabled { get; set; }
Public Property IsStructuralAnalysisEnabled As Boolean
Get
Set
public:
property bool IsStructuralAnalysisEnabled {
bool get ();
void set (bool value);
}
member IsStructuralAnalysisEnabled : bool with get, set
Property Value
Boolean
ExceptionsException | Condition |
---|
InvalidOperationException |
When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
|
Remarks
When structural analysis is disabled the structural analytical model will not be updated
automatically by Revit. Enabling structural analysis will not take effect unless the structure discipline is also enabled.
See Also