ApplicationIsPipingAnalysisEnabled Property |
Checks whether or not piping analysis is enabled, and enable or disable it.
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsPipingAnalysisEnabled { get; set; }
Public Property IsPipingAnalysisEnabled As Boolean
Get
Set
public:
property bool IsPipingAnalysisEnabled {
bool get ();
void set (bool value);
}
member IsPipingAnalysisEnabled : bool with get, set
Property Value
Boolean
ExceptionsException | Condition |
---|
InvalidOperationException |
When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
|
Remarks
Enabling piping analysis will not take effect unless the piping discipline is also enabled.
See Also