ApplicationDefaultViewDiscipline Property

The view discipline that will be applied to new views by default.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ViewDiscipline DefaultViewDiscipline { get; set; }

Property Value

ViewDiscipline
Exceptions
ExceptionCondition
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException When setting this property: This functionality is not available in Revit LT.
Remarks
This view discipline may be overridden by a view template when a view template is also applied to new views.
See Also