ApplicationExtractPartAtomFromFamilyFile Method |
Writes a PartAtom XML from the contents of a family file.
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void ExtractPartAtomFromFamilyFile(
string familyFilePath,
string xmlFilePath
)
Public Sub ExtractPartAtomFromFamilyFile (
familyFilePath As String,
xmlFilePath As String
)
public:
void ExtractPartAtomFromFamilyFile(
String^ familyFilePath,
String^ xmlFilePath
)
member ExtractPartAtomFromFamilyFile :
familyFilePath : string *
xmlFilePath : string -> unit
Parameters
- familyFilePath String
- The family file to be processed.
- xmlFilePath String
- The xml file to be saved.
ExceptionsException | Condition |
---|
ArgumentException |
If 'familyFilePath' or 'xmlFilePath' is or an empty string or if the family file doesn't exist on disk.
|
Remarks
If there is a TXT type catalog next to the family file (a TXT file with the same name as the RFA file),
the function will read it as well and process its contents into PartAtom.
To extract a PartAtom XML from a family loaded into a document in session, use Family.ExtractPartAtom().
See Also