ApplicationOpenDocumentFile(String) Method

Opens a document from disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Document OpenDocumentFile(
	string fileName
)

Parameters

fileName  String
The file to be opened.

Return Value

Document
The opened document.
Exceptions
ExceptionCondition
ArgumentException The fileName to be opened is empty.
ArgumentNullException A non-optional argument was null
CannotOpenBothCentralAndLocalException Cannot open the local model and the central model in the same Revit session. You can close one to open the other in the same Revit session.
CentralModelException Revit encountered serious errors while trying to open the central model.
CorruptModelException There are too many corrupt elements to open this model.
FileAccessException File cannot be opened in Revit LT because it was last saved in a version of Revit prior to 8.1. -or- File has an invalid extension. Try changing the file's extension and opening it again.
FileNotFoundException The fileName to be opened doesn't exist. -or- File Not Found
InsufficientResourcesException This computer does not have enough memory, disk space, or other necessary resource to open the model.
InvalidOperationException Open is temporarily disabled. -or- The document can not be opened.
OperationCanceledException Opening was canceled by the user or by an API event callback.
Remarks
This method opens the document into memory but does not make it visible to the user in any way.
See Also