ApplicationOpenIFCDocument(String) Method

Opens an IFC document from disk using default options.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Document OpenIFCDocument(
	string fileName
)

Parameters

fileName  String
The IFC file to be opened.

Return Value

Document
The newly created document containing the IFC file.
Exceptions
ExceptionCondition
ArgumentException If 'fileName' is an empty string.
ArgumentNullException If is passed as 'fileName' -or- A non-optional argument was null
FileArgumentNotFoundException If the file specified by 'fileName' cannot be found.
InvalidOperationException If Revit is missing document templates or if the file cannot be opened.
See Also