ApplicationIsRouteAnalysisEnabled Property |
Checks whether or not route analysis is enabled, and enable or disable it.
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsRouteAnalysisEnabled { get; set; }
Public Property IsRouteAnalysisEnabled As Boolean
Get
Set
public:
property bool IsRouteAnalysisEnabled {
bool get ();
void set (bool value);
}
member IsRouteAnalysisEnabled : bool with get, set
Property Value
Boolean
ExceptionsException | Condition |
---|
InvalidOperationException |
When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
|
See Also