ApplicationDocumentChanged Event

Subscribe to the DocumentChanged event to be notified when Revit document has changed.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public event EventHandler<DocumentChangedEventArgs> DocumentChanged

Value

EventHandlerDocumentChangedEventArgs
Remarks
This event is raised whenever a Revit transaction is either committed, undone or redone. This is a readonly event, designed to allow you to keep external data in synch with the state of the Revit database. To update the Revit database in response to changes in elements, use the IUpdater framework.
See Also