ApplicationCreate Property |
Provides an object that can be used to create new instances of Autodesk Revit API objects.
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Application Create { get; }
Public ReadOnly Property Create As Application
Get
public:
property Application^ Create {
Application^ get ();
}
member Create : Application with get
Property Value
Application
RemarksThe Create property returns an object that is used to create application wide utility
and geometric objects within the Autodesk Revit API, such as arrays, sets, lines. This object
should be used when you wish to create an object within the Autodesk Revit application memory,
rather than your own application's memory. If you are performing your own memory management
techniques then it is advisable to create any utility objects via the Create object. For example:
Instead of Dim set As New Autodesk_Revit_ElementSet do Set set = application.Create.NewElementSet()
See Also