ApplicationActiveAddInId Property |
Retrieves the Id of the currently running external application.
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic AddInId ActiveAddInId { get; }
Public ReadOnly Property ActiveAddInId As AddInId
Get
public:
property AddInId^ ActiveAddInId {
AddInId^ get ();
}
member ActiveAddInId : AddInId with get
Property Value
AddInId
Remarks
The application can be either a UI application, DB application, or an external command. If no addin is active, this property will return .
If an event handler is currently being executed, the returned value will be the Id of the application or command in which the event handler was registered.
See Also