ApplicationGetLibraryPaths Method |
Returns path information identifying where Revit searches for content.
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IDictionary<string, string> GetLibraryPaths()
Public Function GetLibraryPaths As IDictionary(Of String, String)
public:
IDictionary<String^, String^>^ GetLibraryPaths()
member GetLibraryPaths : unit -> IDictionary<string, string>
Return Value
IDictionaryString,
String
The map of library paths.
Remarks
The map that
is returned contains a key that is purpose of the path, such as Material Libraries and the value
in the map is the fully qualified path that is used for that search path.
Examplestring strLibPaths = "";
foreach (String path in application.GetLibraryPaths().Values)
{
strLibPaths += path + "\n";
}
Dim strLibPaths As String = ""
For Each path As [String] In application.GetLibraryPaths().Values
strLibPaths += path & vbLf
Next
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also