ApplicationProgressChanged Event

Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public event EventHandler<ProgressChangedEventArgs> ProgressChanged

Value

EventHandlerProgressChangedEventArgs
Remarks

Handlers of this event may use the Cancel method to cancel the operation tracked by the progress bar. Users may not change the document in the handler for this event. Exception ModificationForbiddenException will be thrown if any document-modifying method is called during this event's handler.

See Also