ApplicationIsElectricalAnalysisEnabled Property |
Checks whether or not electrical analysis is enabled, and enable or disable it.
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsElectricalAnalysisEnabled { get; set; }
Public Property IsElectricalAnalysisEnabled As Boolean
Get
Set
public:
property bool IsElectricalAnalysisEnabled {
bool get ();
void set (bool value);
}
member IsElectricalAnalysisEnabled : bool with get, set
Property Value
Boolean
ExceptionsException | Condition |
---|
InvalidOperationException |
When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
|
Remarks
Enabling electrical analysis will not take effect unless the electrical discipline is also enabled.
See Also