MaterialSurfaceForegroundPatternId Property |
The id of the FillPatternElement used as the foreground pattern of faces with this material in normal views.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId SurfaceForegroundPatternId { get; set; }
Public Property SurfaceForegroundPatternId As ElementId
Get
Set
public:
property ElementId^ SurfaceForegroundPatternId {
ElementId^ get ();
void set (ElementId^ value);
}
member SurfaceForegroundPatternId : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The element id must represent a valid FillPatternElement.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
Remarks
The FillPattern used for a surface foreground pattern can have a 'Drafting' or a 'Model' target.
See Also