MaterialSetMaterialAspectByPropertySet Method |
Sets an aspect of the material to a shared property set.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetMaterialAspectByPropertySet(
MaterialAspect aspect,
ElementId propertySetId
)
Public Sub SetMaterialAspectByPropertySet (
aspect As MaterialAspect,
propertySetId As ElementId
)
public:
void SetMaterialAspectByPropertySet(
MaterialAspect aspect,
ElementId^ propertySetId
)
member SetMaterialAspectByPropertySet :
aspect : MaterialAspect *
propertySetId : ElementId -> unit
Parameters
- aspect MaterialAspect
-
The material aspect.
- propertySetId ElementId
-
Identifier of a shared property set (an instance of PropertySetElement).
Exceptions
See Also