MaterialIsMaterialOrValidDefault Method |
Validates whether the specified element id is a material element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsMaterialOrValidDefault(
Element pElem,
ElementId materialId
)
Public Shared Function IsMaterialOrValidDefault (
pElem As Element,
materialId As ElementId
) As Boolean
public:
static bool IsMaterialOrValidDefault(
Element^ pElem,
ElementId^ materialId
)
static member IsMaterialOrValidDefault :
pElem : Element *
materialId : ElementId -> bool
Parameters
- pElem Element
-
An element which will be applied the material
- materialId ElementId
-
The element id to be checked.
Return Value
Boolean
True if the element a material element or invalidElementId, which means take material from category, false otherwise.
Exceptions
See Also