MaterialCutForegroundPatternId Property |
The id of the FillPatternElement used as the foreground pattern of faces with this material in cut views.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId CutForegroundPatternId { get; set; }
Public Property CutForegroundPatternId As ElementId
Get
Set
public:
property ElementId^ CutForegroundPatternId {
ElementId^ get ();
void set (ElementId^ value);
}
member CutForegroundPatternId : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The element id must represent a valid FillPatternElement.
-or-
When setting this property: The FillPattern target must be a drafting pattern.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
Remarks
The FillPattern used for a cut foreground pattern must have a 'Drafting' target.
See Also