DimensionOrigin Property

The dimension origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ Origin { get; }

Property Value

XYZ
Exceptions
ExceptionCondition
InvalidOperationException Thrown when:
  • SpotDimension has more than one segments.
Remarks
The origin is the middle point of the dimension line that makes up the dimension. This property is for use with single-segment dimensions only. For multi-segment dimensions use the corresponding property of the DimensionSegment class.
See Also