DimensionLeaderEndPosition Property |
The position of the dimension's leader end point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic XYZ LeaderEndPosition { get; set; }
Public Property LeaderEndPosition As XYZ
Get
Set
public:
property XYZ^ LeaderEndPosition {
XYZ^ get ();
void set (XYZ^ value);
}
member LeaderEndPosition : XYZ with get, set
Property Value
XYZ
ExceptionsException | Condition |
---|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
InvalidOperationException |
Dimension must have leader.
-or-
Thrown when:
- SpotDimension style type is SpotSlope.
- Using equality formula.
- Dimension style is ordinate.
-or-
Thrown when:
- SpotDimension has more than one segments.
-or-
|
RemarksThis property is not applicable to all dimensions.
For example, it is not available for spot slope dimensions, multi-segments dimensions,
dimensions using equality formula, and when dimension style is ordinate.
If the position is not applicable, this property throws InvalidOperationException.
Notes for SpotDimension:
- This property throws InvalidOperationException if dimension has no leader.
- Setting of this property works differently for leader with and without shoulder.
- If leader has shoulder, setting is limited by points on line between leader end and shoulder points (projected point is used).
- Setting of this property also affects TextPosition.
See Also