DimensionFamilyLabel Property |
The family parameter label of the dimension.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FamilyParameter FamilyLabel { get; set; }
Public Property FamilyLabel As FamilyParameter
Get
Set
public:
property FamilyParameter^ FamilyLabel {
FamilyParameter^ get ();
void set (FamilyParameter^ value);
}
member FamilyLabel : FamilyParameter with get, set
Property Value
FamilyParameter
Exceptions
RemarksA dimension only can be labeled to a family parameter in a family document.
When the dimension is labeled by a reporting parameter, the dimension value drives the parameter value.
When the parameter is labeled by a non-reporting, the value of the parameter drives the dimension.
If the dimension is multi-segmented, each segment of the dimension is driven by the same parameter value.
Multi-segmented dimensions cannot be labeled by reporting parameters.
To unbind the family parameter, set this property to .
See Also