DimensionAreReferencesAvailable Property |
Indicates if this dimension's references can be resolved.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool AreReferencesAvailable { get; }
Public ReadOnly Property AreReferencesAvailable As Boolean
Get
public:
property bool AreReferencesAvailable {
bool get ();
}
member AreReferencesAvailable : bool with get
Property Value
Boolean
Remarks
This property always returns true for model dimensions.
It can return false for view-specific dimensions that can lose their
references in certain situations. For example, the host element
references may not be available when the view containing the
dimension is closed. In general, if the host element view-specific
geometry is not available, dimensions that reference that geometry
will not be able to resolve their references.
See Also