DatumPlanePropagateToViews Method |
Propagates the extents applied to this datum in the view to the specified parallel views.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void PropagateToViews(
View view,
ISet<ElementId> parallelViews
)
Public Sub PropagateToViews (
view As View,
parallelViews As ISet(Of ElementId)
)
public:
void PropagateToViews(
View^ view,
ISet<ElementId^>^ parallelViews
)
member PropagateToViews :
view : View *
parallelViews : ISet<ElementId> -> unit
Parameters
- view View
-
The view on which the DatumPlane shows.
- parallelViews ISetElementId
-
The ids of the specified parallel views.
ExceptionsException | Condition |
---|
ArgumentException |
The datum plane cannot be visible in the view.
-or-
One ElementId in parallelViews is not valid for extent propagation.
|
ArgumentNullException |
A non-optional argument was null
|
See Also