DatumPlaneSetCurveInView Method |
Sets the extents to match the curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetCurveInView(
DatumExtentType extentMode,
View view,
Curve curve
)
Public Sub SetCurveInView (
extentMode As DatumExtentType,
view As View,
curve As Curve
)
public:
void SetCurveInView(
DatumExtentType extentMode,
View^ view,
Curve^ curve
)
member SetCurveInView :
extentMode : DatumExtentType *
view : View *
curve : Curve -> unit
Parameters
- extentMode DatumExtentType
-
The extent type.
- view View
-
The view.
- curve Curve
-
The curve.
ExceptionsException | Condition |
---|
ArgumentException |
The datum plane cannot be visible in the view.
-or-
The curve is unbound or not coincident with the original one of the datum plane.
|
ArgumentNullException |
A non-optional argument was null
|
ArgumentOutOfRangeException |
A value passed for an enumeration argument is not a member of that enumeration
|
See Also