DatumPlaneIsCurveValidInView Method |
Checks if the curve is valid to be as the extents for the datum plane in a view.
The curve must be bound and coincident with the original one of the datum plane.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsCurveValidInView(
DatumExtentType extentMode,
View view,
Curve curve
)
Public Function IsCurveValidInView (
extentMode As DatumExtentType,
view As View,
curve As Curve
) As Boolean
public:
bool IsCurveValidInView(
DatumExtentType extentMode,
View^ view,
Curve^ curve
)
member IsCurveValidInView :
extentMode : DatumExtentType *
view : View *
curve : Curve -> bool
Parameters
- extentMode DatumExtentType
-
The extent type.
- view View
-
The view.
- curve Curve
-
The curve.
Return Value
Boolean
True if it is valid, false otherwise.
Exceptions
See Also