DatumPlaneGetDatumExtentTypeInView Method |
Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic DatumExtentType GetDatumExtentTypeInView(
DatumEnds datumEnd,
View view
)
Public Function GetDatumExtentTypeInView (
datumEnd As DatumEnds,
view As View
) As DatumExtentType
public:
DatumExtentType GetDatumExtentTypeInView(
DatumEnds datumEnd,
View^ view
)
member GetDatumExtentTypeInView :
datumEnd : DatumEnds *
view : View -> DatumExtentType
Parameters
- datumEnd DatumEnds
-
Specifies one end of the curve representing the datum plane in the view.
- view View
-
The view in which to evaluate the datum extent settings.
Return Value
DatumExtentType
The extent type.
Exceptions
Remarks
In a particular view, the datum plane is represented by a curve and the two ends of the curve may have different DatumExtentTypes in that view.
See Also