DatumPlaneGetCurvesInView Method |
Gets a collection of curves representing the DatumPlane element in the given view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<Curve> GetCurvesInView(
DatumExtentType extentMode,
View view
)
Public Function GetCurvesInView (
extentMode As DatumExtentType,
view As View
) As IList(Of Curve)
public:
IList<Curve^>^ GetCurvesInView(
DatumExtentType extentMode,
View^ view
)
member GetCurvesInView :
extentMode : DatumExtentType *
view : View -> IList<Curve>
Parameters
- extentMode DatumExtentType
-
The extent type.
- view View
-
The view.
Return Value
IListCurve
The curves.
Exceptions
Remarks
Curves returned for Model extents can be different than curves returned for View-specific extents (2d extents) in the given view.
In some cases, such as an arc grid in a section view, there will be two identical curves but offset from one another.
See Also