AreaReinforcementMoveLine Method

This method applies the translation to the line from the desired layer, at the specified position. If the line was already moved, the method will concatenate the translation with the existing movement. The line will be translated only along the direction of the specified layer.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void MoveLine(
	XYZ translation,
	AreaReinforcementLayerType layer,
	int linePositionIndex
)

Parameters

translation  XYZ
The translation vector.
layer  AreaReinforcementLayerType
The layer on which the line stays.
linePositionIndex  Int32
The index of the line from the desired layer. It should be an index between 0 and (NumberOfLines-1).
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException linePositionIndex is not in the range [ 0, NumberOfLines-1 ]. -or- A value passed for an enumeration argument is not a member of that enumeration
InapplicableDataException The layer layer isn't active.
InvalidOperationException This AreaReinforcement does not host Rebar.
See Also