AreaReinforcementRemoveAreaReinforcementSystem Method |
Deletes the specified AreaReinforcement, and converts its RebarInSystem
elements to equivalent Rebar elements.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<ElementId> RemoveAreaReinforcementSystem(
Document doc,
AreaReinforcement system
)
Public Shared Function RemoveAreaReinforcementSystem (
doc As Document,
system As AreaReinforcement
) As IList(Of ElementId)
public:
static IList<ElementId^>^ RemoveAreaReinforcementSystem(
Document^ doc,
AreaReinforcement^ system
)
static member RemoveAreaReinforcementSystem :
doc : Document *
system : AreaReinforcement -> IList<ElementId>
Parameters
- doc Document
-
The document.
- system AreaReinforcement
-
An AreaReinforcement element in the document.
Return Value
IListElementId
The ids of the newly created Rebar elements.
Exceptions
See Also