AreaReinforcementGetBoundaryCurveIds Method |
Retrieves the set of curves forming the boundary of the Area Reinforcement.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<ElementId> GetBoundaryCurveIds()
Public Function GetBoundaryCurveIds As IList(Of ElementId)
public:
IList<ElementId^>^ GetBoundaryCurveIds()
member GetBoundaryCurveIds : unit -> IList<ElementId>
Return Value
IListElementId
A collection of ElementIds of AreaReinforcementCurve elements.
Remarks
Each ElementId in the collection is an Id of an Element of type AreaReinforcementCurve. Each element has a Curve property
to retrieve the geometric curve, together with some Parameters allowing the developer to override the clear cover side,
hook type, and hook direction of each layer of bars terminating at the curve.
See Also