AreaReinforcementGetMovedLineTransform Method |
Returns a transform representing the movement of the line relative to its default position along the direction of the desired layer.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Transform GetMovedLineTransform(
AreaReinforcementLayerType layer,
int linePositionIndex
)
Public Function GetMovedLineTransform (
layer As AreaReinforcementLayerType,
linePositionIndex As Integer
) As Transform
public:
Transform^ GetMovedLineTransform(
AreaReinforcementLayerType layer,
int linePositionIndex
)
member GetMovedLineTransform :
layer : AreaReinforcementLayerType *
linePositionIndex : int -> Transform
Parameters
- layer AreaReinforcementLayerType
-
The layer on which the line stays.
- linePositionIndex Int32
-
The index of the line from the desired layer. It should be an index between 0 and (NumberOfLines-1).
Return Value
Transform
The transform representing the movement of the line relative to its default position along the direction of the desired layer.
Exceptions
See Also