AreaReinforcementResetMovedLineTransform Method

Reset the transformation representing the movement of the line relative to its default position along the direction of the specified layer. The moved line transform will be set to Identity.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ResetMovedLineTransform(
	AreaReinforcementLayerType layer,
	int linePositionIndex
)

Parameters

layer  AreaReinforcementLayerType
The layer on which the line stays.
linePositionIndex  Int32
The index of the line from the desired layer. It should be an index between 0 and (NumberOfLines-1).
Exceptions
ExceptionCondition
ArgumentOutOfRangeException linePositionIndex is not in the range [ 0, NumberOfLines-1 ]. -or- A value passed for an enumeration argument is not a member of that enumeration
InapplicableDataException The layer layer isn't active.
InvalidOperationException This AreaReinforcement does not host Rebar.
See Also