NurbSpline Class

A nurb spline.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBGeometryObject
      Autodesk.Revit.DBCurve
        Autodesk.Revit.DBNurbSpline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class NurbSpline : Curve

The NurbSpline type exposes the following members.

Properties
 NameDescription
Public propertyCtrlPointsReturns the control points of the nurb spline.
Public propertyDegreeReturns the degree of the nurb spline.
Public propertyisRationalReturns whether the nurb spline is rational or not.
Public propertyKnotsReturn/set the knots of the nurb spline.
Public propertyWeightsReturns the weights of the nurb spline.
Top
Methods
 NameDescription
Public methodStatic memberCreate Creates a new geometric NurbSpline object from a HermiteSpline.
Public methodStatic memberCreateCurve(HermiteSpline) Creates a new geometric Curve object by converting the given HermiteSpline. The created curve may be a NURBSpline or a simpler curve such as line or arc.
Public methodStatic memberCreateCurve(IListXYZ, IListDouble) Creates a new geometric Curve object from NURBS curve data containing just control points and weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
Public methodStatic memberCreateCurve(Int32, IListDouble, IListXYZ) Creates a new geometric Curve object from NURBS curve data, which does not include weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
Public methodStatic memberCreateCurve(Int32, IListDouble, IListXYZ, IListDouble) Creates a new geometric Curve object from NURBS curve data, which includes weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
Public methodSetControlPointsAndWeightsSet the control points, weights simultaneously.
Top
Remarks
The nurb spline lies in the plane defined by control point, weight,knots,degree.
See Also