NurbSpline Class

A nurb spline.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBGeometryObject
      Autodesk.Revit.DBCurve
        Autodesk.Revit.DBNurbSpline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class NurbSpline : Curve

The NurbSpline type exposes the following members.

Properties
 NameDescription
Public propertyApproximateLengthThe approximate length of the curve.
(Inherited from Curve)
Public propertyCtrlPointsReturns the control points of the nurb spline.
Public propertyDegreeReturns the degree of the nurb spline.
Public propertyCode exampleGraphicsStyleIdThe ElementId of the GeometryObject's GraphicsStyle
(Inherited from GeometryObject)
Public propertyIdA unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
(Inherited from GeometryObject)
Public propertyIsBoundDescribes whether the parameter of the curve is restricted to a particular interval.
(Inherited from Curve)
Public propertyIsClosedDescribes whether the curve is closed.
(Inherited from Curve)
Public propertyIsCyclicThe boolean value that indicates whether this curve is cyclic.
(Inherited from Curve)
Public propertyIsElementGeometryIndicates whether this geometry is obtained directly from an Element.
(Inherited from GeometryObject)
Public propertyisRationalReturns whether the nurb spline is rational or not.
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyKnotsReturn/set the knots of the nurb spline.
Public propertyLengthThe exact length of the curve.
(Inherited from Curve)
Public propertyPeriodThe period of this curve.
(Inherited from Curve)
Public propertyReferenceReturns a stable reference to the curve.
(Inherited from Curve)
Public propertyVisibilityThe visibility.
(Inherited from GeometryObject)
Public propertyWeightsReturns the weights of the nurb spline.
Top
Methods
 NameDescription
Public methodCloneReturns a copy of this curve.
(Inherited from Curve)
Public methodComputeClosestPoints Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance.
(Inherited from Curve)
Public methodComputeDerivatives Returns the vectors describing the curve at the specified parameter.
(Inherited from Curve)
Public methodComputeNormalizedParameterComputes the normalized curve parameter from the raw parameter.
(Inherited from Curve)
Public methodComputeRawParameterComputes the raw parameter from the normalized parameter.
(Inherited from Curve)
Public methodStatic memberCreate Creates a new geometric NurbSpline object from a HermiteSpline.
Public methodStatic memberCreateCurve(HermiteSpline) Creates a new geometric Curve object by converting the given HermiteSpline. The created curve may be a NURBSpline or a simpler curve such as line or arc.
Public methodStatic memberCreateCurve(IListXYZ, IListDouble) Creates a new geometric Curve object from NURBS curve data containing just control points and weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
Public methodStatic memberCreateCurve(Int32, IListDouble, IListXYZ) Creates a new geometric Curve object from NURBS curve data, which does not include weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
Public methodStatic memberCreateCurve(Int32, IListDouble, IListXYZ, IListDouble) Creates a new geometric Curve object from NURBS curve data, which includes weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
Public methodCreateOffset Creates a new curve that is an offset of the existing curve.
(Inherited from Curve)
Public methodCreateReversed Creates a new curve with the opposite orientation of the existing curve.
(Inherited from Curve)
Public methodCreateTransformed Crates a new instance of a curve as a transformation of this curve.
(Inherited from Curve)
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodDistanceReturns the shortest distance from the specified point to this curve.
(Inherited from Curve)
Public methodEquals Determines whether the specified Object is equal to the current Object.
(Inherited from GeometryObject)
Public methodEvaluate Evaluates and returns the point that matches a parameter along the curve.
(Inherited from Curve)
Public methodGetEndParameter Returns the raw parameter value at the start or end of this curve.
(Inherited from Curve)
Public methodGetEndPoint Returns the 3D point at the start or end of this curve.
(Inherited from Curve)
Public methodGetEndPointReferenceReturns a stable reference to the start point or the end point of the curve.
(Inherited from Curve)
Public methodGetHashCode Gets the integer value of the geometry object as hash code
(Inherited from GeometryObject)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIntersect(Curve)Calculates the intersection of this curve with the specified curve.
(Inherited from Curve)
Public methodIntersect(Curve, IntersectionResultArray)Calculates the intersection of this curve with the specified curve and returns the intersection results.
(Inherited from Curve)
Public methodIsInside(Double)Indicates whether the specified parameter value is within this curve's bounds.
(Inherited from Curve)
Public methodIsInside(Double, Int32)Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.
(Inherited from Curve)
Public methodMakeBoundChanges the bounds of this curve to the specified values.
(Inherited from Curve)
Public methodMakeUnboundMakes this curve unbound.
(Inherited from Curve)
Public methodProjectProjects the specified point on this curve.
(Inherited from Curve)
Public methodSetControlPointsAndWeightsSet the control points, weights simultaneously.
Public methodSetGraphicsStyleIdSets the graphics style id for this curve.
(Inherited from Curve)
Public methodTessellateValid only if the curve is bound. Returns a polyline approximation to the curve.
(Inherited from Curve)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The nurb spline lies in the plane defined by control point, weight,knots,degree.
See Also