CurveApproximateLength Property |
The approximate length of the curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double ApproximateLength { get; }
Public ReadOnly Property ApproximateLength As Double
Get
public:
property double ApproximateLength {
double get ();
}
member ApproximateLength : float with get
Property Value
Double
Exceptions
RemarksQuickly estimates the length of the curve, may deviate by a factor of 2 in some cases.
The computation is exact for lines and arcs.
See Also