Evaluates and returns the point that matches a parameter along the curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic XYZ Evaluate(
double parameter,
bool normalized
)
Public Function Evaluate (
parameter As Double,
normalized As Boolean
) As XYZ
public:
XYZ^ Evaluate(
double parameter,
bool normalized
)
member Evaluate :
parameter : float *
normalized : bool -> XYZ
Parameters
- parameter Double
-
The parameter to be evaluated.
- normalized Boolean
-
If false, param is interpreted as natural parameterization of the curve.
If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.
Return Value
XYZ
The point evaluated along the curve.
ExceptionsException | Condition |
---|
ArgumentException |
The given value for parameter is not finite
|
ArgumentOutOfRangeException |
The curve cannot be evaluated as normalized because it is unbound.
-or-
The parameter is not a valid value for normalized evaluation.
|
See Also