Curve Class

A parametric curve.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBGeometryObject
      Autodesk.Revit.DBCurve
        More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Curve : GeometryObject

The Curve type exposes the following members.

Properties
 NameDescription
Public propertyApproximateLengthThe approximate length of the curve.
Public propertyCode exampleGraphicsStyleIdThe ElementId of the GeometryObject's GraphicsStyle
(Inherited from GeometryObject)
Public propertyIdA unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
(Inherited from GeometryObject)
Public propertyIsBoundDescribes whether the parameter of the curve is restricted to a particular interval.
Public propertyIsClosedDescribes whether the curve is closed.
Public propertyIsCyclicThe boolean value that indicates whether this curve is cyclic.
Public propertyIsElementGeometryIndicates whether this geometry is obtained directly from an Element.
(Inherited from GeometryObject)
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyLengthThe exact length of the curve.
Public propertyPeriodThe period of this curve.
Public propertyReferenceReturns a stable reference to the curve.
Public propertyVisibilityThe visibility.
(Inherited from GeometryObject)
Top
Methods
 NameDescription
Public methodCloneReturns a copy of this curve.
Public methodComputeClosestPoints Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance.
Public methodComputeDerivatives Returns the vectors describing the curve at the specified parameter.
Public methodComputeNormalizedParameterComputes the normalized curve parameter from the raw parameter.
Public methodComputeRawParameterComputes the raw parameter from the normalized parameter.
Public methodCreateOffset Creates a new curve that is an offset of the existing curve.
Public methodCreateReversed Creates a new curve with the opposite orientation of the existing curve.
Public methodCreateTransformed Crates a new instance of a curve as a transformation of this curve.
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodDistanceReturns the shortest distance from the specified point to this curve.
Public methodEquals Determines whether the specified Object is equal to the current Object.
(Inherited from GeometryObject)
Public methodEvaluate Evaluates and returns the point that matches a parameter along the curve.
Public methodGetEndParameter Returns the raw parameter value at the start or end of this curve.
Public methodGetEndPoint Returns the 3D point at the start or end of this curve.
Public methodGetEndPointReferenceReturns a stable reference to the start point or the end point of the curve.
Public methodGetHashCode Gets the integer value of the geometry object as hash code
(Inherited from GeometryObject)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIntersect(Curve)Calculates the intersection of this curve with the specified curve.
Public methodIntersect(Curve, IntersectionResultArray)Calculates the intersection of this curve with the specified curve and returns the intersection results.
Public methodIsInside(Double)Indicates whether the specified parameter value is within this curve's bounds.
Public methodIsInside(Double, Int32)Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.
Public methodMakeBoundChanges the bounds of this curve to the specified values.
Public methodMakeUnboundMakes this curve unbound.
Public methodProjectProjects the specified point on this curve.
Public methodSetGraphicsStyleIdSets the graphics style id for this curve.
Public methodTessellateValid only if the curve is bound. Returns a polyline approximation to the curve.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The concrete curves are defined by parametric equations. If the curve is bound, it is only defined for an interval in parameterization. Otherwise, it is defined for all values of the parameter.
See Also
Inheritance Hierarchy