APIObjectIsReadOnly Property |
Identifies if the object is read-only or modifiable.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
Get
public:
virtual property bool IsReadOnly {
bool get ();
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get
Property Value
BooleanIf true, the object may not be modified. If false, the object's contents may be modified.
ExampleDocument project = uiApplication.ActiveUIDocument.Document;
Settings settings = project.Settings;
TaskDialog.Show("Revit","Categories: " + settings.Categories.IsReadOnly.ToString());
Dim project As Document = uiApplication.ActiveUIDocument.Document
Dim settings As Settings = project.Settings
TaskDialog.Show("Revit", "Categories: " + settings.Categories.IsReadOnly.ToString())
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also