CurveIntersect(Curve) Method |
Calculates the intersection of this curve with the specified curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic SetComparisonResult Intersect(
Curve curve
)
Public Function Intersect (
curve As Curve
) As SetComparisonResult
public:
SetComparisonResult Intersect(
Curve^ curve
)
member Intersect :
curve : Curve -> SetComparisonResult
Parameters
- curve Curve
- The specified curve to intersect with this curve.
Return Value
SetComparisonResult- SetComparisonResult.Overlap - One or more intersections were encountered.
- SetComparisonResult.Subset - The inputs are parallel lines with only one common intersection point, or
the curve used to invoke the intersection check is a line entirely within the unbound line passed as argument curve.
- SetComparisonResult.Superset - The input curve is entirely within the unbound line used to invoke the intersection check.
- SetComparisonResult.Disjoint - There is no intersection found between the two curves.
- SetComparisonResult.Equal - The two curves are identical.
Exceptions
See Also