CurveIntersect(Curve, IntersectionResultArray) Method |
Calculates the intersection of this curve with the specified curve and returns the intersection results.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic SetComparisonResult Intersect(
Curve curve,
out IntersectionResultArray resultArray
)
Public Function Intersect (
curve As Curve,
<OutAttribute> ByRef resultArray As IntersectionResultArray
) As SetComparisonResult
public:
SetComparisonResult Intersect(
Curve^ curve,
[OutAttribute] IntersectionResultArray^% resultArray
)
member Intersect :
curve : Curve *
resultArray : IntersectionResultArray byref -> SetComparisonResult
Parameters
- curve Curve
- The specified curve to intersect with this curve.
- resultArray IntersectionResultArray
- Provides more information about the intersection.
Return Value
SetComparisonResult- SetComparisonResult.Overlap - One or more intersections were encountered. The output argument has the details.
- SetComparisonResult.Subset - The inputs are parallel lines with only one common intersection point, or
the curve used to invoke the intersection check is a line entirely within the unbound line passed as argument curve.
If the former, the output argument has the details of the intersection point.
- SetComparisonResult.Superset - The input curve is entirely within the unbound line used to invoke the intersection check.
- SetComparisonResult.Disjoint - There is no intersection found between the two curves.
- SetComparisonResult.Equal - The two curves are identical.
Exceptions
Remarks
The array of the intersection results contains one entry for each point where curves intersect.
The following is the meaning of IntersectionResult members:
- XYZPoint is the evaluated intersection point
- UVPoint.U is the unnormalized parameter on this curve (use ComputeNormalizedParameter to compute the normalized value).
- UVPoint.V is the unnormalized parameter on the specified curve (use ComputeNormalizedParameter to compute the normalized value).
See Also