CurveIsInside(Double, Int32) Method |
Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsInside(
double parameter,
out int end
)
Public Function IsInside (
parameter As Double,
<OutAttribute> ByRef end As Integer
) As Boolean
public:
bool IsInside(
double parameter,
[OutAttribute] int% end
)
member IsInside :
parameter : float *
end : int byref -> bool
Parameters
- parameter Double
- The raw curve parameter to be evaluated.
- end Int32
- The end index is equal to 0 for the start point, 1 for the end point, or -1 if the parameter is not at the end.
Return Value
BooleanTrue if the parameter is within the curve's bounds, otherwise false.
RemarksAlways returns true if this curve is unbound.
See Also