NurbSplineCreateCurve(HermiteSpline) Method |
Creates a new geometric Curve object by converting the given HermiteSpline.
The created curve may be a NURBSpline or a simpler curve such as line or arc.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Curve CreateCurve(
HermiteSpline hermiteSpline
)
Public Shared Function CreateCurve (
hermiteSpline As HermiteSpline
) As Curve
public:
static Curve^ CreateCurve(
HermiteSpline^ hermiteSpline
)
static member CreateCurve :
hermiteSpline : HermiteSpline -> Curve
Parameters
- hermiteSpline HermiteSpline
-
The HermiteSpline that will be converted.
Return Value
Curve
The new Curve object.
ExceptionsException | Condition |
---|
ArgumentException |
The given hermite spline has to be non-periodic.
-or-
Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
|
ArgumentNullException |
A non-optional argument was NULL
|
Remarks
The function does not support periodic Hermite curve.
See Also