GeometryObjectGraphicsStyleId Property |
The ElementId of the GeometryObject's GraphicsStyle
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId GraphicsStyleId { get; }
Public ReadOnly Property GraphicsStyleId As ElementId
Get
public:
property ElementId^ GraphicsStyleId {
ElementId^ get ();
}
member GraphicsStyleId : ElementId with get
Property Value
ElementId
RemarksThis property provides the id of the GraphicsStyle assigned to the GeometryObject.
This can be used to find the category of the object.
Example
Options options = app.Create.NewGeometryOptions();
GeometryElement geomElem = element.get_Geometry(options);
foreach (GeometryObject geomObj in geomElem)
{
GeometryInstance geomInst = geomObj as GeometryInstance;
if (geomInst != null)
{
foreach (Object obj in geomInst.SymbolGeometry)
{
GeometryObject geomObject = obj as GeometryObject;
GraphicsStyle gStyle = doc.GetElement(geomObject.GraphicsStyleId) as GraphicsStyle;
if (gStyle != null)
{
string gstyleName = gStyle.GraphicsStyleCategory.Name;
}
}
}
}
Dim options As Options = app.Create.NewGeometryOptions()
Dim geomElem As GeometryElement = element.Geometry(options)
For Each geomObj As GeometryObject In geomElem
Dim geomInst As GeometryInstance = TryCast(geomObj, GeometryInstance)
If geomInst IsNot Nothing Then
For Each obj As [Object] In geomInst.SymbolGeometry
Dim geomObject As GeometryObject = TryCast(obj, GeometryObject)
Dim gStyle As GraphicsStyle = TryCast(doc.GetElement(geomObject.GraphicsStyleId), GraphicsStyle)
If gStyle IsNot Nothing Then
Dim gstyleName As String = gStyle.GraphicsStyleCategory.Name
End If
Next
End If
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also