FamilyItemFactory Class

The Family Item Factory object is used to create new instances of elements within the Autodesk Revit Family.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.CreationItemFactoryBase
      Autodesk.Revit.CreationFamilyItemFactory

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FamilyItemFactory : ItemFactoryBase

The FamilyItemFactory type exposes the following members.

Properties
 NameDescription
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodNewAlignmentAdd a new locked alignment into the Autodesk Revit document.
(Inherited from ItemFactoryBase)
Public methodNewAngularDimension(View, Arc, Reference, Reference) Creates a new angular dimension object using the default dimension type.
Public methodNewAngularDimension(View, Arc, Reference, Reference, DimensionType) Creates a new angular dimension object using the specified dimension type.
Public methodCode exampleNewArcLengthDimension(View, Arc, Reference, Reference, Reference) Creates a new arc length dimension object using the default dimension type.
Public methodNewArcLengthDimension(View, Arc, Reference, Reference, Reference, DimensionType) Creates a new arc length dimension object using the specified dimension type.
Public methodCode exampleNewBlendAdd a new Blend instance into the Autodesk Revit family document.
Public methodNewControlAdd a new control into the Autodesk Revit family document.
Public methodCode exampleNewCurveByPointsCreate a 3d curve through two or more points in an Autodesk Revit family document.
Public methodNewDetailCurve Creates a new detail curve element.
(Inherited from ItemFactoryBase)
Public methodNewDetailCurveArray Creates an array of new detail curve elements.
(Inherited from ItemFactoryBase)
Public methodNewDiameterDimension Creates a new diameter dimension object using the default dimension type.
Public methodCode exampleNewDimension(View, Line, ReferenceArray) Creates a new linear dimension object using the default dimension style.
(Inherited from ItemFactoryBase)
Public methodNewDimension(View, Line, ReferenceArray, DimensionType) Creates a new linear dimension object using the specified dimension style.
(Inherited from ItemFactoryBase)
Public methodCode exampleNewExtrusionAdd a new Extrusion instance into the Autodesk Revit family document.
Public methodCode exampleNewExtrusionFormCreate new Form element by Extrude operation, and add it into the Autodesk Revit family document.
Public methodCode exampleNewFamilyInstance(Face, Line, FamilySymbol)Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
(Inherited from ItemFactoryBase)
Public methodCode exampleNewFamilyInstance(Line, FamilySymbol, View)Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.
(Inherited from ItemFactoryBase)
Public methodCode exampleNewFamilyInstance(Reference, Line, FamilySymbol)Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol.
(Inherited from ItemFactoryBase)
Public methodNewFamilyInstance(XYZ, FamilySymbol, StructuralType)Inserts a new instance of a family into the document, using a location and a type/symbol.
(Inherited from ItemFactoryBase)
Public methodNewFamilyInstance(XYZ, FamilySymbol, View)Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.
(Inherited from ItemFactoryBase)
Public methodCode exampleNewFamilyInstance(Face, XYZ, XYZ, FamilySymbol)Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.
(Inherited from ItemFactoryBase)
Public methodCode exampleNewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol)Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol.
(Inherited from ItemFactoryBase)
Public methodCode exampleNewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType)Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.
(Inherited from ItemFactoryBase)
Public methodNewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType)Inserts a new instance of a family into the document, using a location, type/symbol, and the level.
(Inherited from ItemFactoryBase)
Public methodCode exampleNewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType)Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.
(Inherited from ItemFactoryBase)
Public methodCode exampleNewFamilyInstances2 Creates Family instances within the document.
(Inherited from ItemFactoryBase)
Public methodNewFormByCapCreate new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.
Public methodNewFormByThickenSingleSurfaceCreate a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
Public methodCode exampleNewGroupCreates a new type of group.
(Inherited from ItemFactoryBase)
Public methodCode exampleNewLinearDimension(View, Line, ReferenceArray) Generate a new linear dimension object using the default dimension type.
Public methodNewLinearDimension(View, Line, ReferenceArray, DimensionType) Creates a new linear dimension object using the specified dimension type.
Public methodCode exampleNewLoftFormCreate new Form element by Loft operation, and add it into the Autodesk Revit family document.
Public methodCode exampleNewModelCurve Creates a new model line element.
(Inherited from ItemFactoryBase)
Public methodNewModelCurveArray Creates an array of new model line elements.
(Inherited from ItemFactoryBase)
Public methodNewModelTextCreate a model text in the Autodesk Revit family document.
Public methodNewOpeningCreate an opening to cut the wall or ceiling.
Public methodNewRadialDimension(View, Reference, XYZ) Creates a new radial dimension object using the default dimension type.
Public methodNewRadialDimension(View, Reference, XYZ, DimensionType) Generate a new radial dimension object using a specified dimension type.
Public methodCode exampleNewReferencePlane Creates a new instance of ReferencePlane.
(Inherited from ItemFactoryBase)
Public methodCode exampleNewReferencePlane2 Creates a new instance of ReferencePlane.
(Inherited from ItemFactoryBase)
Public methodNewReferencePoint(PointElementReference)Create a reference point on an existing reference in an Autodesk Revit family document.
Public methodNewReferencePoint(Transform)Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.
Public methodNewReferencePoint(XYZ)Create a reference point at a given location in an Autodesk Revit family document.
Public methodCode exampleNewRevolutionAdd a new Revolution instance into the Autodesk Revit family document.
Public methodCode exampleNewRevolveFormsCreate new Form elements by revolve operation, and add them into the Autodesk Revit family document.
Public methodNewSweep(Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation)Adds a new sweep form into the family document, using an array of selected references as a 3D path.
Public methodCode exampleNewSweep(Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation)Adds a new sweep form to the family document, using a path of curve elements.
Public methodNewSweptBlend(Boolean, Reference, SweepProfile, SweepProfile)Adds a new swept blend into the family document, using a selected reference as the path.
Public methodCode exampleNewSweptBlend(Boolean, Curve, SketchPlane, SweepProfile, SweepProfile)Add a new swept blend into the family document, using a curve as the path.
Public methodNewSweptBlendFormCreate new Form element by swept blend operation, and add it into the Autodesk Revit family document.
Public methodNewSymbolicCurveCreate a symbolic curve in an Autodesk Revit family document.
Public methodPlaceGroupPlace an instance of a Model Group into the Autodesk Revit document, using a location and a group type.
(Inherited from ItemFactoryBase)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The Family Item Factory object is a utility object that is used to create new instances of elements within the Autodesk Revit Family Document. This object should be used to create elements instead of using New. This object ensures that the elements created are added to the family document correctly.
See Also